Announcement

Collapse
No announcement yet.

why display nothing?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • why display nothing?

    I create a viewer with programming(Qt4.6.3+Openinventor8.02),it is ok. When I put the programs(dlls and exe) files on the other computer,the black viewer cann't display.Could you tell me why?thank you!
    I use SoQtExaminerViewer class and getWidget() method to integrate Qt and Openinventor.
    Attached Files

  • #2
    Originally posted by Mike_new View Post
    I create a viewer with programming(Qt4.6.3+Openinventor8.02),it is ok. When I put the programs(dlls and exe) files on the other computer,the black viewer cann't display.Could you tell me why?thank you!
    I use SoQtExaminerViewer class and getWidget() method to integrate Qt and Openinventor.
    I program on window7 and run the exe file on window7.

    Comment


    • #3
      Hi there! I was programming yesterday at my real estate in Czech Republic here but on windows8 and looks like I have a similar issue. Can anyone help us please?
      Last edited by Puzion; October 16, 2020, 04:05 PM.

      Comment


      • #4
        Originally posted by Mike_new View Post
        I create a viewer with programming(Qt4.6.3+Openinventor8.02),it is ok. When I put the programs(dlls and exe) files on the other computer,the black viewer cann't display.Could you tell me why?thank you!
        I use SoQtExaminerViewer class and getWidget() method to integrate Qt and Openinventor.
        Hi,
        It should work, however you are using a very old version of Open Inventor and we will not be able to debug the problem with that version.
        Some things to consider:
        - What is different between these two computers? (where one works and one does not work)
        - Consider using a current version of Open Inventor.
        Regards,
        Mike

        Comment


        • #5
          Dear Mike,
          Thank you for your answer.The difference between these two computers is, one compter which I program on ,the other is not. Could you tell me the essential elements for OpenInventor to run?

          Comment


          • #6
            Originally posted by Mike_new View Post
            Dear Mike,
            Thank you for your answer.The difference between these two computers is, one compter which I program on ,the other is not. Could you tell me the essential elements for OpenInventor to run?
            Hi,
            System requirements for Open Inventor 9.x are available here. The requirements for OIV 8 should be similar.

            Try building and running a very simple OIV program that just uses the SoWin/SoXt classes, for example 02.4.Examiner in the Mentor examples directory. If that works on both machines, then there is no problem with core Open Inventor, but there may be a problem with the Qt runtime.
            Regards,
            Mike

            Comment


            • #7
              Thank you,Dear Mike.I will try.

              Comment

              Working...
              X